Skip to content

Example: interop1: ipip tunnel

Alt text

r1

hostname r1
vrf def v1
 rd 1:1
 exit
int eth1
 vrf for v1
 ipv4 addr 1.1.1.1 255.255.255.0
 ipv6 addr 1234::1 ffff::
 exit
int tun1
 tunnel vrf v1
 tunnel mode ipip
 tunnel source ethernet1
 tunnel destination 1.1.1.2
 vrf for v1
 ipv4 addr 2.2.2.1 255.255.255.0
 ipv6 addr 2222::1 ffff::
 exit

r2

hostname r2
ip routing
ipv6 unicast-routing
interface gigabit1
 ip address 1.1.1.2 255.255.255.0
 ipv6 address 1234::2/64
 no shutdown
 exit
interface tunnel1
 tunnel source gigabit1
 tunnel destination 1.1.1.1
 tunnel mode ipip
 ip address 2.2.2.2 255.255.255.0
 exit
interface tunnel2
 tunnel source gigabit1
 tunnel destination 1.1.1.1
 tunnel mode ipv6ip
 ipv6 address 2222::2/64
 exit
r1 tping 100 10 1.1.1.2 vrf v1
r1 tping 100 10 1234::2 vrf v1
r1 tping 100 10 2.2.2.2 vrf v1
r1 tping 100 10 2222::2 vrf v1
  1. Install ContainerLab as described here
  2. Fetch intop1-tun02 file
  3. Launch ContainerLab intop1-tun02.yml topology:

   containerlab deploy --topo intop1-tun02.yml  
4. Destroy ContainerLab intop1-tun02.yml topology:

   containerlab destroy --topo intop1-tun02.yml  
5. Copy-paste configuration for each node in the lab topology

  1. Fetch or compile freeRtr rtr.jar file.
    You can grab it here
  2. Fetch intop1-tun02.tst file here
  3. Launch intop1-tun02.tst test:

   java -jar ../../rtr.jar test tester intop1-tun02 path ./ temp ./ wait
4. Destroy freeRtr intop1-tun02.tst test:

   Ctrl-C (In freeRtr test window)