Skip to content

Example: interop1: ospf text authentication

Alt text

r1

hostname r1
vrf def v1
 rd 1:1
 exit
router ospf4 1
 vrf v1
 router 4.4.4.1
 area 0 ena
 red conn
 exit
router ospf6 1
 vrf v1
 router 6.6.6.1
 area 0 ena
 red conn
 exit
int eth1
 vrf for v1
 ipv4 addr 1.1.1.1 255.255.255.0
 ipv6 addr fe80::1 ffff::
 router ospf4 1 ena
 router ospf4 1 password tester
 router ospf6 1 ena
 exit
int lo0
 vrf for v1
 ipv4 addr 2.2.2.1 255.255.255.255
 ipv6 addr 4321::1 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
 exit

r2

hostname r2
ip routing
ipv6 unicast-routing
interface loopback0
 ip addr 2.2.2.2 255.255.255.255
 ipv6 addr 4321::2/128
 exit
router ospf 1
 redistribute connected subnets
 exit
ipv6 router ospf 1
 redistribute connected
 exit
interface gigabit1
 ip address 1.1.1.2 255.255.255.0
 ipv6 enable
 ip ospf network point-to-point
 ip ospf authentication
 ip ospf authentication-key tester
 ip ospf 1 area 0
 ipv6 ospf network point-to-point
 ipv6 ospf 1 area 0
 no shutdown
 exit
r1 tping 100 10 1.1.1.2 vrf v1
r1 tping 100 60 2.2.2.2 vrf v1 sou lo0
r1 tping 100 60 4321::2 vrf v1 sou lo0
  1. Install ContainerLab as described here
  2. Fetch intop1-ospf09 file
  3. Launch ContainerLab intop1-ospf09.yml topology:

   containerlab deploy --topo intop1-ospf09.yml  
4. Destroy ContainerLab intop1-ospf09.yml topology:

   containerlab destroy --topo intop1-ospf09.yml  
5. Copy-paste configuration for each node in the lab topology

  1. Fetch or compile freeRtr rtr.jar file.
    You can grab it here
  2. Fetch intop1-ospf09.tst file here
  3. Launch intop1-ospf09.tst test:

   java -jar ../../rtr.jar test tester intop1-ospf09 path ./ temp ./ wait
4. Destroy freeRtr intop1-ospf09.tst test:

   Ctrl-C (In freeRtr test window)