Skip to content

Example: interop1: isis narrow metric

Alt text

r1

hostname r1
vrf def v1
 rd 1:1
 exit
router isis4 1
 vrf v1
 net 48.4444.0000.1111.00
 no metric-wide
 red conn
 exit
router isis6 1
 vrf v1
 net 48.6666.0000.1111.00
 no metric-wide
 red conn
 exit
int eth1
 vrf for v1
 ipv4 addr 1.1.1.1 255.255.255.0
 router isis4 1 ena
 exit
int eth2
 vrf for v1
 ipv6 addr fe80::1 ffff::
 router isis6 1 ena
 exit
int lo0
 vrf for v1
 ipv4 addr 2.2.2.1 255.255.255.255
 ipv6 addr 4321::1 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
 exit

r2

hostname r2
ip routing
ipv6 unicast-routing
interface loopback0
 ip addr 2.2.2.2 255.255.255.255
 ipv6 addr 4321::2/128
 exit
router isis
 net 48.0000.0000.1234.00
 metric-style narrow
 redistribute connected
 address-family ipv6
  redistribute connected
 exit
interface gigabit1
 ip address 1.1.1.2 255.255.255.0
 isis network point-to-point
 ip router isis
 no shutdown
 exit
interface gigabit2
 ipv6 enable
 isis network point-to-point
 ipv6 router isis
 no shutdown
 exit
r1 tping 100 10 1.1.1.2 vrf v1
r1 tping 100 60 2.2.2.2 vrf v1 sou lo0
r1 tping 100 60 4321::2 vrf v1 sou lo0
  1. Install ContainerLab as described here
  2. Fetch intop1-isis04 file
  3. Launch ContainerLab intop1-isis04.yml topology:

   containerlab deploy --topo intop1-isis04.yml  
4. Destroy ContainerLab intop1-isis04.yml topology:

   containerlab destroy --topo intop1-isis04.yml  
5. Copy-paste configuration for each node in the lab topology

  1. Fetch or compile freeRtr rtr.jar file.
    You can grab it here
  2. Fetch intop1-isis04.tst file here
  3. Launch intop1-isis04.tst test:

   java -jar ../../rtr.jar test tester intop1-isis04 path ./ temp ./ wait
4. Destroy freeRtr intop1-isis04.tst test:

   Ctrl-C (In freeRtr test window)