Example: interop8: bgp authentication¶
r1
hostname r1
vrf def v1
rd 1:1
exit
int eth1
vrf for v1
ipv4 addr 1.1.1.1 255.255.255.0
ipv6 addr 1234::1 ffff::
exit
int lo0
vrf for v1
ipv4 addr 2.2.2.1 255.255.255.255
ipv6 addr 4321::1 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
exit
router bgp4 1
vrf v1
address uni
local-as 1
router-id 4.4.4.1
neigh 1.1.1.2 remote-as 1
neigh 1.1.1.2 password tester
red conn
exit
router bgp6 1
vrf v1
address uni
local-as 1
router-id 6.6.6.1
neigh 1234::2 remote-as 1
neigh 1234::2 password tester
red conn
exit
r2
hostname r2
ip forwarding
ipv6 forwarding
interface lo
ip addr 2.2.2.2/32
ipv6 addr 4321::2/128
exit
interface ens3
ip address 1.1.1.2/24
ipv6 address 1234::2/64
no shutdown
exit
router bgp 1
neighbor 1.1.1.1 remote-as 1
neighbor 1234::1 remote-as 1
neighbor 1.1.1.1 password tester
neighbor 1234::1 password tester
address-family ipv4 unicast
neighbor 1.1.1.1 activate
no neighbor 1234::1 activate
redistribute connected
address-family ipv6 unicast
no neighbor 1.1.1.1 activate
neighbor 1234::1 activate
redistribute connected
exit
r1 tping 100 10 1.1.1.2 vrf v1
r1 tping 100 10 1234::2 vrf v1
r1 tping 100 60 2.2.2.2 vrf v1 sou lo0
r1 tping 100 60 4321::2 vrf v1 sou lo0
- Install ContainerLab as described here
- Fetch intop8-bgp11 file
- Launch ContainerLab
intop8-bgp11.yml
topology:
containerlab deploy --topo intop8-bgp11.yml
intop8-bgp11.yml
topology:
containerlab destroy --topo intop8-bgp11.yml